Ducati Diavel Motorcycles Forum banner
1 - 20 of 29 Posts

·
Registered
Joined
·
550 Posts
Discussion Starter · #1 ·
Yep. Happily riding over the bridge north at lunch time today and suffered a complete loss of power. No warning. Nothing.

Fortunately for me I had crested the centre of the bridge and was able to coast most of the way down the other side. I managed to push the bike the rest of the way off the road at the Milsons Point exit.

Off to Fraser on the back of a trailer again. Will be interested to see what they come up with.
 

Attachments

·
Registered
Joined
·
2,693 Posts
Something about the Diavel having personality. Simply wanted to stop and enjoy the view perhaps?

More seriously, I hope you get it sorted soon.
 

·
Registered
Joined
·
550 Posts
Discussion Starter · #4 ·
Thanks Wahoo.

No, General, no sign of life at all. Dead as a doornail. I seem to remember that someone had a similar problem to this, and I searched but couldn't find it. Does it ring a bell with you?
 

·
Registered
Joined
·
321 Posts
Mono,
On a trailer again? What happened last time?
Also, I see you have the full mudguard still on...do the NSW coppers ping you if it is removed?
 

·
Drop Bear Slayer
Joined
·
8,437 Posts
I remember a member here having their rear wheel damages from having it tied down through the rear wheel like that.
Worth checking.
I can't help with the problem you suffered at all though.
Hope it gets sorted quickly.

 

·
Registered
Joined
·
2,389 Posts

·
Registered
Joined
·
550 Posts
Discussion Starter · #9 ·
Mono,
On a trailer again? What happened last time?
Also, I see you have the full mudguard still on...do the NSW coppers ping you if it is removed?
Hi Mate.

It has been on the trailer and fixed under warranty before for:

Coolant leak.
Not starting - dud battery.

It has also been on the trailer for a punctured rear tyre. But hey, you get that.

As for the mudguard, I have not got around to having it removed. But yes, according to the dealer, it is illegal in NSW to remove it.
 

·
Registered
Joined
·
550 Posts
Discussion Starter · #10 ·
I remember a member here having their rear wheel damages from having it tied down through the rear wheel like that.
Worth checking.
I can't help with the problem you suffered at all though.
Hope it gets sorted quickly.

Cheers Coop.
 

·
Registered
Joined
·
2,389 Posts
Thanks Wahoo.

No, General, no sign of life at all. Dead as a doornail. I seem to remember that someone had a similar problem to this, and I searched but couldn't find it. Does it ring a bell with you?
Rings a bell. I will look while I'm at work.
 

·
Registered
Joined
·
277 Posts
That mudguard is something else. If you had to combine it with the Japanese long exhausts it might change my mind about this bike in general. Sorry to say, but that is pretty ugly.

Good luck on fixing the problem. I had all my dash lights go out, but that was just a fuse but the bike kept running. Could it be a main power fuse?
 

·
Registered
Joined
·
2,389 Posts

·
Esquire
Joined
·
3,039 Posts
mono i had a loss of engine power after a shift drum replacement work order was completed. found out it was the Throttle position sensor that failed on me, for safety reasons it cut engine power and would not start because throttle was in open position when failed. turned out to be a bad electrical connector that was overlooked at during the service tech.
 

·
Registered
Joined
·
2,693 Posts
Whats with the undress the wheel fettish? I'm keeping mine on, it works.

And Mono, that is a damb nice looking bike, even though it is red.
 
  • Like
Reactions: Mono

·
Registered
Joined
·
2,693 Posts
What was the verdict Mono? Something to do with the kill switch perhaps?
 

·
Registered
Joined
·
2,693 Posts
That mudguard is something else. If you had to combine it with the Japanese long exhausts it might change my mind about this bike in general. Sorry to say, but that is pretty ugly.
 

·
Registered
Joined
·
321 Posts
I see in an earlier photo of your bike (months ago) you had left the guard on. I had mine removed (and didn't bother collecting it) cause I thought, like others it made the bike look ugly. I asked the local dealer if I needed one to get it over the pits (due to a misunderstanding with the cops) could I get one. He said yes no probs, we would dig one up from somewhere so comfortable with that. So far, no issues but have only ridden around the South West and to the Drags in Kwinana, will be doing a ride into Perth in around a week so I will see how it goes.
 
1 - 20 of 29 Posts
Top