Jump to content


Gen2 Fuel gauge stuck on three bars


17 replies to this topic

#1 Bumblesocks

    Member

  • Members
  • PipPip
  • 86 posts
    Joined: 09-March 14
  • Location: Seattle WA, USA
  • Diavel Model: Dark

Posted 31 March 2017 - 06:33 PM

Hi guys,

My Diavel Gen 2 2015's fuel gauge has decided to stick at 3 bars no matter how much fuel is in the tank. Any suggestions on debugging and fixing this, or is it back to the dealer?

Have gone back to using Trip 1 as God intended in the meantime.

-Bumble

Remove Advertisements Sponsored Links

    Diavel-Forum.com



#2 JoeFishNC

    Advanced Member

  • Members
  • PipPipPip
  • 375 posts
    Joined: 19-September 13
  • Location: NC
  • Diavel Model: Carbon Red

Posted 01 April 2017 - 01:18 PM

common issue...I have had 2 replaced...

#3 caboose

    Member

  • Members
  • PipPip
  • 36 posts
    Joined: 10-October 16
  • Location: Paso Robles, CA
  • Diavel Model: Dark

Posted 04 April 2017 - 04:55 AM

Just had mine replaced ~ a month ago.

#4 MarLin2015

    Newbie

  • Members
  • Pip
  • 1 posts
    Joined: 08-May 17
  • Location: Washington
  • Diavel Model: Carbon White

Posted 08 May 2017 - 07:57 AM

Yesterday I ran out of gas on my 2015 Diavel Carbon. It was stuck on 3 bars and the low fuel light was not on and said I had 74 miles of range remaining. I had a friend bring me some gas and when I filled it at the gas station I remained with 3 bars showing on the gas gauge. Later after I got home I reset the trip 1 and then noticed later the tank was showing full. I"ve never in my life ran out of gas and to have it happen on a bike with 1006 miles on it is frustrating that it's already acting up.

#5 Rex in the Big Easy!

    Expert Member

  • Members
  • PipPipPipPip
  • 4,499 posts
    Joined: 08-November 14
  • Location: Big Easy (New Orleans)
  • Diavel Model: Carbon Red

Posted 08 May 2017 - 10:55 AM

View PostMarLin2015, on 08 May 2017 - 07:57 AM, said:

Yesterday I ran out of gas on my 2015 Diavel Carbon. It was stuck on 3 bars and the low fuel light was not on and said I had 74 miles of range remaining. I had a friend bring me some gas and when I filled it at the gas station I remained with 3 bars showing on the gas gauge. Later after I got home I reset the trip 1 and then noticed later the tank was showing full. I"ve never in my life ran out of gas and to have it happen on a bike with 1006 miles on it is frustrating that it's already acting up.


With such few miles on a 2.5 year old bike, may have something to do with 10% ethanol additives to gas.
Cant leave that shit set up for any length of time, AFAIK.

Mine's the first Gen2 same year w/21K miles so far, and run ethanol gas since then ... no problems.
Wish could be said for ongoing DSB Slave Error issues. :(


#6 Kenek

    Advanced Member

  • Members
  • PipPipPip
  • 242 posts
    Joined: 01-June 15
  • Location: Tampa, FL
  • Diavel Model: Carbon White

Posted 08 May 2017 - 12:59 PM

My fuel gauge was broken on day one. Warranty repair. I'll bet for every one Diavel without this problem there are ten with it.

#7 dansax

    Advanced Member

  • Members
  • PipPipPip
  • 413 posts
    Joined: 11-May 16
  • Location: Port Jeff, NY
  • Diavel Model: Dark

Posted 10 May 2017 - 01:56 AM

Fuel gauge is iffy even when it works.

#8 Roadrunner

    Expert Member

  • Members
  • PipPipPipPip
  • 1,244 posts
    Joined: 13-July 15
  • Location: Arizona
  • Diavel Model: Carbon White

Posted 10 May 2017 - 02:32 AM

This should've been recalled years ago. Every Duc with a fuel gauge has suffered from this. Mine was replaced under warranty nearly 10,000 miles ago and I haven't had an issue since.

#9 enjoymentman

    Advanced Member

  • Members
  • PipPipPip
  • 212 posts
    Joined: 13-March 11
  • Location: Lagos, Nigeria.
  • Diavel Model: Titanium

Posted 17 June 2017 - 09:18 AM

I've just returned from the first ride on my Titanium, apparently my gauge is stuck on the last bar. I had thought i just needed to fill up, did twice over the 140 mile ride, it's still stuck. Damn.

#10 Rex in the Big Easy!

    Expert Member

  • Members
  • PipPipPipPip
  • 4,499 posts
    Joined: 08-November 14
  • Location: Big Easy (New Orleans)
  • Diavel Model: Carbon Red

Posted 17 June 2017 - 09:52 AM

Fuck that fuel gauge!

Mine's been flaky lately too @ 22K miles. This morning I filled up. Reads about 3/4th's full on a full tank.



#11 Roadrunner

    Expert Member

  • Members
  • PipPipPipPip
  • 1,244 posts
    Joined: 13-July 15
  • Location: Arizona
  • Diavel Model: Carbon White

Posted 17 June 2017 - 06:18 PM

View Postenjoymentman, on 17 June 2017 - 09:18 AM, said:

I've just returned from the first ride on my Titanium, apparently my gauge is stuck on the last bar. I had thought i just needed to fill up, did twice over the 140 mile ride, it's still stuck. Damn.


I'm shocked.....


Not so much, really. That freakin' thing has gone out on nearly every Diavel ever made, as far I know lol. It's a quick fix though and it's a well known and documented issue. I had mine replaced a little over 10K miles ago and haven't had an issue with it since. Just under 18,000 miles on the bike and the fuel gauge is the only issue I've had. Let's hope it works out the same for you

Edited by Roadrunner, 17 June 2017 - 06:18 PM.


#12 enjoymentman

    Advanced Member

  • Members
  • PipPipPip
  • 212 posts
    Joined: 13-March 11
  • Location: Lagos, Nigeria.
  • Diavel Model: Titanium

Posted 17 June 2017 - 10:45 PM

View PostRoadrunner, on 17 June 2017 - 06:18 PM, said:


I'm shocked.....


Not so much, really. That freakin' thing has gone out on nearly every Diavel ever made, as far I know lol. It's a quick fix though and it's a well known and documented issue. I had mine replaced a little over 10K miles ago and haven't had an issue with it since. Just under 18,000 miles on the bike and the fuel gauge is the only issue I've had. Let's hope it works out the same for you

😁 I'll get it sorted.

Sent from my SM-G955F using Tapatalk



#13 Rex in the Big Easy!

    Expert Member

  • Members
  • PipPipPipPip
  • 4,499 posts
    Joined: 08-November 14
  • Location: Big Easy (New Orleans)
  • Diavel Model: Carbon Red

Posted 18 June 2017 - 11:37 AM

View PostRoadrunner, on 17 June 2017 - 06:18 PM, said:


I'm shocked.....


Not so much, really. That freakin' thing has gone out on nearly every Diavel ever made, as far I know lol. It's a quick fix though and it's a well known and documented issue. I had mine replaced a little over 10K miles ago and haven't had an issue with it since. Just under 18,000 miles on the bike and the fuel gauge is the only issue I've had. Let's hope it works out the same for you


WTF Bud...No leaking clutch/brake reservoirs in 18K?

#14 Roadrunner

    Expert Member

  • Members
  • PipPipPipPip
  • 1,244 posts
    Joined: 13-July 15
  • Location: Arizona
  • Diavel Model: Carbon White

Posted 18 June 2017 - 11:55 AM

Nope. Not one drop. And I've flushed the brakes and clutch 3 times now, I think.

#15 dansax

    Advanced Member

  • Members
  • PipPipPip
  • 413 posts
    Joined: 11-May 16
  • Location: Port Jeff, NY
  • Diavel Model: Dark

Posted 18 June 2017 - 06:53 PM

After a fill up mine won't register full when I restart it. It does the next time I turn it on. Should have been upgraded from the factory by now.

#16 Kenek

    Advanced Member

  • Members
  • PipPipPip
  • 242 posts
    Joined: 01-June 15
  • Location: Tampa, FL
  • Diavel Model: Carbon White

Posted 19 June 2017 - 05:26 AM

Out riding on Friday, distance to empty reads 32 miles, all of a sudden dash shows a big red warning "Fuel Sensor!" Along with check-engine light. Both go out after about a half mile. A few minutes later both come on again, but go out again as well. Rode over to the dealer, discussed with the service tech, will schedule a replacement sensor this week. He even stated that this is a well documented issue for both the Diavel and the Multi.

#17 dansax

    Advanced Member

  • Members
  • PipPipPip
  • 413 posts
    Joined: 11-May 16
  • Location: Port Jeff, NY
  • Diavel Model: Dark

Posted Today, 10:33 AM

Just got the red fuel sensor light going on and off today. What a shit system.

#18 Rex in the Big Easy!

    Expert Member

  • Members
  • PipPipPipPip
  • 4,499 posts
    Joined: 08-November 14
  • Location: Big Easy (New Orleans)
  • Diavel Model: Carbon Red

Posted Today, 12:18 PM

View Postdansax, on 25 June 2017 - 10:33 AM, said:

Just got the red fuel sensor light going on and off today. What a shit system.


LoL! That's chump change to fix my Brutha!!

Just wait till you get DSB Slave Error message when factory warranty has expired w/out any extended warranty coverage.
Will you say BOHICA???? Don't forget to bring along the KY. Doesn't hurt as much:)





1 user(s) are reading this topic

0 members, 1 guests, 0 anonymous users